auf Facebook teilen auf Google+ teilen auf LinkedIn teilen auf Pinterest teilen twittern
Werbehinweise
» Startseite » Blog » Linux: »Warning: No Support for locale: de_DE.utf8« 

Blog

August 2017 April 2017 März 2017 Februar 2017 Dezember 2016 Juli 2016 Februar 2016 Januar 2016 Oktober 2015 Juli 2015 Juni 2015 März 2015 Januar 2015 Dezember 2014 November 2014 Oktober 2014 September 2014 Juni 2014 April 2014 März 2014 Februar 2014 Januar 2014 Dezember 2013 November 2013 Oktober 2013 August 2013 Juli 2013 März 2013 Februar 2013 Januar 2013 Dezember 2012 November 2012 Oktober 2012 September 2012 Zarges »Brotkiste« (Lizenznachbau aus GB) Linux: »Warning: No Support for locale: de_DE.utf8« Abwandlung der »Serviettentechnik« an der Alukiste von Zarges Canon IP4000: Druckt keinen Text mehr aus August 2012 Juli 2012 Juni 2012 Mai 2012 April 2012 März 2012 Februar 2012 Januar 2012 Dezember 2011 November 2011 Oktober 2011 September 2011 August 2011 Juli 2011 Juni 2011 Mai 2011 April 2011 März 2011 Februar 2011 Januar 2011 Dezember 2010 November 2010 Oktober 2010 September 2010 August 2010 Juli 2010 Juni 2010 Mai 2010 April 2010 März 2010 Februar 2010 Januar 2010 Dezember 2009 November 2009 Oktober 2009 September 2009 Januar 2009 Dezember 2008 November 2008 Oktober 2008 September 2008 Juni 2008 Mai 2008 April 2008 März 2008 Februar 2008 Januar 2008 Dezember 2007 November 2007 Oktober 2007 Mai 2007 Februar 2007 Januar 2007 September 2006 August 2006 Juni 2006 Mai 2006 April 2006 März 2006 Februar 2006 November 2005 Oktober 2005 September 2005 Juli 2005 Juni 2005 Mai 2005 Mai 2004 Oktober 2003 September 2003 Juli 2003 Juni 2002 Mai 2002 März 2002 Februar 2002 Januar 2002 November 2001 Oktober 2001 Juli 2001 Juni 2001 Mai 2001 März 2001 Februar 2001 Januar 2001
get Opera
get Mozilla Firefox
get Konqueror
get Mozilla Thunderbird
get Ubuntu Linux

Anzeige
ALL-INKL.COM - Webhosting Server Hosting Domain Provider

10.

September

2012

Linux: »Warning: No Support for locale: de_DE.utf8«

Nach einem manuellen Update von meinem Linux Mint begrüste mich beim Start nun folgende Meldung:

 Warning: No Support for locale: de_DE.utf8 

Wenig erfreulich, denn neben der Meldung kommt auch bei einigen Anwendungen der Hinweis darauf, dass die ausgewählte Sprache »de_DE.utf8« nicht verfügbar sei.

Auf der Suche nach einer Lösung für das Problem wurde ich in der deutschsprachigen Ubuntu-Wiki[1] fündig. Vier Aufrufe an der Konsole genügen um das Problem zu beheben. Da in dem Beitrag in der Wiki die Ausgaben nach den jeweiligen Aufrufen nicht mit angegeben wurden, gehe ich in meinem heutigen Blog-Beitrag darauf ein.

Die einzugebenden Befehlszeilen sind fett hervorgehoben. Die Ausgaben an der Konsole sind nicht fett markiert.

Der erste Befehl welcher an der Konsole eingegeben werden muss lautet wie folgt:

 sudo dpkg-reconfigure locales 

Die Ausgabe nach dem Absenden des Aufrufs sieht wie folgt aus:

 Generating locales... de_AT.UTF-8... done de_BE.UTF-8... done de_CH.UTF-8... done de_DE.UTF-8... done de_LI.UTF-8... done de_LU.UTF-8... done en_AG.UTF-8... up-to-date en_AU.UTF-8... up-to-date en_BW.UTF-8... up-to-date en_CA.UTF-8... up-to-date en_DK.UTF-8... up-to-date en_GB.UTF-8... up-to-date en_HK.UTF-8... up-to-date en_IE.UTF-8... up-to-date en_IN.UTF-8... up-to-date en_NG.UTF-8... up-to-date en_NZ.UTF-8... up-to-date en_PH.UTF-8... up-to-date en_SG.UTF-8... up-to-date en_US.UTF-8... up-to-date en_ZA.UTF-8... up-to-date en_ZM.UTF-8... up-to-date en_ZW.UTF-8... up-to-date Generation complete. 

Anschließend soll die in der Fehlermeldung angegebene Eintrag zu LOCALE aktualisiert werden:

 sudo update-locale LANG=de_DE.UTF-8 

Es erfolgt keine Rückmeldung nach dem Absenden dieses Aufrufs. Der nächste Aufruf kann sofort eingegeben werden:

 sudo locale-gen --purge --no-archive 

Die Ausgabe fällt wieder umfangreich aus:

 Generating locales... de_AT.UTF-8... done de_BE.UTF-8... done de_CH.UTF-8... done de_DE.UTF-8... done de_LI.UTF-8... done de_LU.UTF-8... done en_AG.UTF-8... done en_AU.UTF-8... done en_BW.UTF-8... done en_CA.UTF-8... done en_DK.UTF-8... done en_GB.UTF-8... done en_HK.UTF-8... done en_IE.UTF-8... done en_IN.UTF-8... done en_NG.UTF-8... done en_NZ.UTF-8... done en_PH.UTF-8... done en_SG.UTF-8... done en_US.UTF-8... done en_ZA.UTF-8... done en_ZM.UTF-8... done en_ZW.UTF-8... done 

Der vierte und letzte Aufruf lautet:

 sudo update-initramfs -u -k all 

Je nachdem wie viele Kernel man installiert hat, dauert das Abarbeiten ein wenig länger. In meinem Fall dauerte es ein klein wenig länger...

 update-initramfs: Generating /boot/initrd.img-3.2.0-34-generic update-initramfs: Generating /boot/initrd.img-3.2.0-33-generic update-initramfs: Generating /boot/initrd.img-3.2.0-32-generic update-initramfs: Generating /boot/initrd.img-3.2.0-31-generic update-initramfs: Generating /boot/initrd.img-3.2.0-30-generic update-initramfs: Generating /boot/initrd.img-3.2.0-29-generic update-initramfs: Generating /boot/initrd.img-3.0.0-23-generic update-initramfs: Generating /boot/initrd.img-3.0.0-22-generic update-initramfs: Generating /boot/initrd.img-3.0.0-19-generic update-initramfs: Generating /boot/initrd.img-3.0.0-17-generic update-initramfs: Generating /boot/initrd.img-3.0.0-12-generic 

Anschließend sollte nach einem Neustart die Fehlermeldung dauerhaft verschwunden sein.

X_FISH



 
 
Das Generieren dieser Seite dauerte genau 0.06182 Sekunden.